Welcome to the North American Subaru Impreza Owners Club Thursday December 14, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-29-2001, 09:42 PM   #1
jay25RS
Scooby Specialist
 
Member#: 4273
Join Date: Feb 2001
Chapter/Region: NESIC
Location: CT
Vehicle:
2015 Taco
& 2015 Legacy Ltd.

Default Help! I need to know what this green thing is!

Ok everyone; here is a tough question that I would like to have answered. What is the unconnected green connector under the driver’s side dash for? (Read on for more information.) I was under my dash today on the driver’s side of my MY01 2.5RS Sedan. I was securing a wire for my subwoofer toggle switch, which had come loose, and to my surprise, I saw a green connecter that has 2 wires (the 2 wires are black and red) going into each half which was disconnected! I reconnected them and then when I turned my key to the “on” position the one just before start, my Check Engine light began to flash and it seemed like the ECU went through a self test diagnostic routine. The radiator fans cycled on and off and the (maybe) fuel pump noise reoccurred several times. I panicked and then removed my key and then unconnected the connector. I then tried turning the key to the “on” position once again just before the start position. Everything was normal. I started my car and then proceeded to “rev” the engine to about 4000RPM’s to see if a CEL plague had bitten me so I guess that it hasn’t. The car idled smooth and accelerates strongly and smoothly just as it has done so in the past. I wonder if I did any damage to my car by doing this…??? So does anyone have any idea what this is actually for? BTW I have a 5 spd in case that info is needed.

Thank you!
Jason
* Registered users of the site do not see these ads.
jay25RS is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-29-2001, 09:53 PM   #2
North Ursalia
Miss You Mom
Oct 1940 - Feb 2008

Super Moderator
 
Member#: 809
Join Date: Jan 2000
Chapter/Region: NESIC
Location: NH, Land Of Many Trees
Vehicle:
2000 2.5 RS, '14 For
92 5MT SVX

Default

You're fine- those two connectors are put together when the car is being transported, and are disco'd at PDI .

Brian
AIM: captaindamorgan ICQ: 84483950
http://www.northursalia.com
http://www.imprezamods.com
http://www.scoobymods.com
Ph33r me, for I am root
North Ursalia is offline   Reply With Quote
Old 07-29-2001, 10:08 PM   #3
jay25RS
Scooby Specialist
 
Member#: 4273
Join Date: Feb 2001
Chapter/Region: NESIC
Location: CT
Vehicle:
2015 Taco
& 2015 Legacy Ltd.

Default

Thank you Brian for allowing me to sleep easy tonight.
jay25RS is offline   Reply With Quote
Old 07-29-2001, 10:16 PM   #4
Safir
Scooby Guru
 
Member#: 3873
Join Date: Jan 2001
Location: Tampa, FL
Vehicle:
. Paradise is
like Disney with hookers

Default

rumor has it this connector and another are used to do an ECU reset without disconnecting the battery and taking 30 minutes.
Safir is offline   Reply With Quote
Old 07-29-2001, 11:17 PM   #5
Sparko
Scooby Newbie
 
Member#: 3040
Join Date: Nov 2000
Location: Surrey, BC, Canada
Wink

Really? I thought it was prewiring for a trunk monkey.
Sparko is offline   Reply With Quote
Old 07-29-2001, 11:41 PM   #6
dbrier
Scooby Guru
 
Member#: 6598
Join Date: May 2001
Chapter/Region: MWSOC
Location: West side of Indianapolis
Vehicle:
2017 Golf R
Limestone Grey

Default

I found this on an Austrailian site and it refers to the WRX, but I'm not sure if they mean the 2002 model. http://www.wrx.org.au/tech/index.html#ecu_reset
It confims what Safir said....
dbrier is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I need to know what this is and I'm lost. KyleRGAJ Interior & Exterior Modification 10 02-20-2010 11:31 AM
i need to know what this peice is called and where to buy besides the dealership knighter General Community 3 08-12-2008 04:54 PM
Price for new wrx ??? Going to buy one tomorrow and need to know what a good deal is Sausage Tri-State Area Forum 43 04-21-2007 12:21 AM
need to know what this fuse is matt6669 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 58 06-30-2005 01:10 AM
Need to know what this is! Kari Electrical & Lighting 3 11-20-2003 01:14 AM

All times are GMT -4. The time now is 12:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.