Welcome to the North American Subaru Impreza Owners Club Saturday January 25, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-26-2006, 09:23 PM   #1
kenithzs
Scooby Newbie
 
Member#: 118270
Join Date: Jun 2006
Default Engine sputter at high RPM?

After about 15 minutes of hard driving at high RPM's, my '00 2.5RS will stall out at around 4500 RPM. It will then run as normal for a few minutes and then sputter out to the point where I cannot get it over 1500 RPM. Once the problem starts it snowballs until the car barely runs, Then I'll let it sit for about 5 minutes and it will run fine for five minutes and then sputter down to low RPM. The next day it will run strong for 15 minutes and then repeat. I pulled the code with the scantool program and it gave me P0463- Fuel Level Sensor High Input. The car was sitting still for a couple of years before I got it so I would not be surprised to find out that the sending units in the tank were hosed before this problem cropped up. If this error is the problem, could a fuel level sensor wreck things this badly?
Assuming that the error code was pre-existing, could these be the symptoms of a fuel pump/relay gone bad? I was thinking that perhaps it is extremly filthy injectors, but then again, why would it only occur after the car gets warmed up?



Thanks, any advice or info would be great.
-Ken
kenithzs is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine "stutters" at high rpm and after corners? Help please masterpickle Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 28 09-03-2008 03:57 PM
engine hesitates at high rpm tsukuba speed Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 9 12-24-2007 06:36 AM
2.2l Engine whistle at high RPM boyleia1 Normally Aspirated Powertrain 11 10-24-2007 05:37 PM
chek engine light at high rpm bigislandracing Off-Topic 18 07-19-2007 08:22 PM
engine sputtering at High Rev full throttle app. outback bosco Service & Maintenance 3 01-26-2002 11:17 PM

All times are GMT -4. The time now is 04:08 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.