Welcome to the North American Subaru Impreza Owners Club Sunday January 26, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 09-20-2018, 11:40 AM   #1001
SirBrass
Scooby Specialist
 
Member#: 207263
Join Date: Apr 2009
Chapter/Region: MWSOC
Location: Indianapolis area
Vehicle:
2019 WRX Limited
World Rally Blue

Default

Quote:
Originally Posted by geddesk2 View Post
Hi all looking for help!

I purchased a new to me 2013 fxt touring that comes with the standard underseat sub.

The previous owner installed a pioneer double din deck. Everything works with the exception of the under seat subwoofer.

Is it possible to get it working? I can't find any information on the underseat subwoofer that came in the touring as it looks totally different than the optional upgrade offered by subaru.
Is it powered or does it need an amp?

If it's powered, then the inputs should all be taps on speaker level outputs to the door speakers.
* Registered users of the site do not see these ads.
SirBrass is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-21-2018, 01:55 PM   #1002
dawmon77
Scooby Newbie
 
Member#: 491653
Join Date: Sep 2018
Location: Canada
Vehicle:
2011 Impreza Sti
White

Default

Quote:
Originally Posted by dawmon77 View Post
Hello there,

Are you still selling your custom made harness?
Looking to buy one for my Impreza 2011, I have an old pioneer AVIC-U310BT and got hold of a Kenwood FXDB09KF2.
I also send you an email on [email protected] for a quote.

Hope to hear from you soon

Regards

Davide
It looks like SVXdc has gone quiet, does anybody know here if/were i can find harness adaptors similar to the ones he was making? Or where i can source connectors to make my own harness?

Thanks in advance

Davide
dawmon77 is offline   Reply With Quote
Old 09-25-2018, 01:31 AM   #1003
CXVninja84
Scooby Newbie
 
Member#: 438216
Join Date: Jan 2016
Default

You could check with the guys at http://autoharnesshouse.com. They have done custom built harnesses for a number of the members on here.
CXVninja84 is offline   Reply With Quote
Old 09-28-2018, 07:09 PM   #1004
kirz
Scooby Newbie
 
Member#: 492053
Join Date: Sep 2018
Default

Hi. I have a major problem on my BRZ. I have complete no sound on my speakers and i can't select the FM station on the head unit only AM station can be selected. What can be my problem?
I would appreciate your help on this issue.

P.S.: sorry for my bad English, English is not my birth language...
kirz is offline   Reply With Quote
Old 09-28-2018, 07:43 PM   #1005
SirBrass
Scooby Specialist
 
Member#: 207263
Join Date: Apr 2009
Chapter/Region: MWSOC
Location: Indianapolis area
Vehicle:
2019 WRX Limited
World Rally Blue

Default

Quote:
Originally Posted by kirz View Post
Hi. I have a major problem on my BRZ. I have complete no sound on my speakers and i can't select the FM station on the head unit only AM station can be selected. What can be my problem?
I would appreciate your help on this issue.

P.S.: sorry for my bad English, English is not my birth language...
FM & AM are coming in through your antenna, but are decoded differently. I'd say something went wrong in your FM demodulating circuitry.

Are you using a stock or aftermarket HU?
SirBrass is offline   Reply With Quote
Old 09-28-2018, 07:47 PM   #1006
kirz
Scooby Newbie
 
Member#: 492053
Join Date: Sep 2018
Default

Quote:
Originally Posted by SirBrass View Post
FM & AM are coming in through your antenna, but are decoded differently. I'd say something went wrong in your FM demodulating circuitry.

Are you using a stock or aftermarket HU?
Stock. The HU doesn't let change to the FM, i press it but it doesn't change always stays in AM.
For exemple, if have selected the CD player and then select the FM, it change automatically to the AM and don't stay in the FM.
kirz is offline   Reply With Quote
Old 09-28-2018, 09:34 PM   #1007
sdswingr
Scooby Newbie
 
Member#: 491377
Join Date: Sep 2018
Location: Idaho Falls, ID
Vehicle:
2013 Subaru STI
Black

Default

So, on my 2013 STI (US car) I started getting a message on startup saying "check antenna", relating to the satellite radio antenna, was working fine, but finally stopped getting a signal. So now I am without my sat radio, which is really annoying.
Is this a simple problem of needing a new antenna, or has the receiver actually gone bad?
sdswingr is offline   Reply With Quote
Old 09-28-2018, 09:47 PM   #1008
SirBrass
Scooby Specialist
 
Member#: 207263
Join Date: Apr 2009
Chapter/Region: MWSOC
Location: Indianapolis area
Vehicle:
2019 WRX Limited
World Rally Blue

Default

Quote:
Originally Posted by kirz View Post
Stock. The HU doesn't let change to the FM, i press it but it doesn't change always stays in AM.
For exemple, if have selected the CD player and then select the FM, it change automatically to the AM and don't stay in the FM.
That is a jacked up HU. How old is it?
SirBrass is offline   Reply With Quote
Old 09-28-2018, 09:52 PM   #1009
kirz
Scooby Newbie
 
Member#: 492053
Join Date: Sep 2018
Default

Quote:
Originally Posted by SirBrass View Post
That is a jacked up HU. How old is it?
Sorry i can't understand the question. The HU is like this

I don't know the exact year of manufacture, i would have to confirm it on the car.

P.S.: the car it self is from 2015 so i would say the HU have 3 years.

Edit: in relation to the speakers with no sound, anyone knows what could be?

Last edited by kirz; 09-29-2018 at 10:11 AM.
kirz is offline   Reply With Quote
Old 10-26-2018, 04:06 PM   #1010
kirz
Scooby Newbie
 
Member#: 492053
Join Date: Sep 2018
Default

Bump. Anyone with knowledge about my topic could please help me...
kirz is offline   Reply With Quote
Old 11-15-2018, 02:53 PM   #1011
pdximpreza
Scooby Newbie
 
Member#: 17606
Join Date: Apr 2002
Chapter/Region: NWIC
Location: Portland area, OR
Vehicle:
2008 STI hatchback
Silver

Default

I am so glad this information was available. I got a 2008 STI with factory Nav, it took a bit of digging to this thread. And its really the only place that has the factory Nav harness info. Still not sure if I was supposed to use illum + or -. Guess i'll find tonight on the drive to work.
pdximpreza is offline   Reply With Quote
Old 11-20-2018, 05:00 PM   #1012
pdximpreza
Scooby Newbie
 
Member#: 17606
Join Date: Apr 2002
Chapter/Region: NWIC
Location: Portland area, OR
Vehicle:
2008 STI hatchback
Silver

Default

Well I have ran into one problem. One I think I got the wrong Illum wire, that not big. But the real problem is I can't get CAN data. I have installed a JVC KW-M740T with the idatalink ADS-MRR and its getting an OBD2 error using the CAN H and L as labelled here. It says to go to the OBD2 port, but dang it I ran out of butt splices.
pdximpreza is offline   Reply With Quote
Old 02-06-2019, 05:52 AM   #1013
Evil_Iguana
Scooby Newbie
 
Member#: 497403
Join Date: Feb 2019
Default

Quote:
Originally Posted by dawmon77 View Post
It looks like SVXdc has gone quiet, does anybody know here if/were i can find harness adaptors similar to the ones he was making? Or where i can source connectors to make my own harness?

Thanks in advance

Davide
Has anyone managed to get in touch with him?

I would like to upgrade from the base CZ601U1 to the Kenwood NAVI FXDB09EF2. Already send him two e-mail but I have no feedback from him.

Or if you know another way to source the cable i would be really thankful.
Evil_Iguana is offline   Reply With Quote
Old 02-10-2019, 11:17 PM   #1014
thatgarrett
Scooby Newbie
 
Member#: 497099
Join Date: Jan 2019
Location: TN
Vehicle:
2007 Outback Sport
Urban Gray

Default

After digging through here for the last couple of days, I canít find much up to date information for a 2007 Impreza radio (with stock AUX) options for BT or USB integration into the stock HU. I have the unused port for SAT radio, but even if the 2008+ iPod dock would work the 30pin connected wouldnít. Iíve been there and done aftermarket HUís before, but this time I want to stay stock.

Any good aftermarket fixes or stock hacks? I just want control over skipping tracks through the radio at this point
thatgarrett is offline   Reply With Quote
Old 03-01-2019, 12:32 AM   #1015
stotty5
Scooby Newbie
 
Member#: 498413
Join Date: Feb 2019
Chapter/Region: International
Location: Auckland, New Zealand
Vehicle:
2007 Impreza GH7 JDM

Default

Quote:
Originally Posted by maxfiles25 View Post
I have the new 2008 WRX STI and found that the BLuetooth mic did not come with the car. SO I had the Dealer order the part. After 5 weeks it came in and I laughed once I saw it. $198 for a 3 wire connection with mic that mounts on stearing column. I looked at the instructions and pin outs. It connects up to the back of the radio to 3 pins and that is it.
So I returned and said no thanks. I went out and bought a $10.00 computer mic from Wal-Mart and $1.99 9 Pin Computer Female adapter from Radio Shack that you put together. I just needed it for the small female pin outs. Since the back of the radio has the Male Pins.



The connector on the back is the black one almost in the middle/center right..
next to the little white one. 5 Male Pins are in it.



The Mic has two wires (Positive & Negative) You need to splice a second Negative Ground off the Mics Original Ground. To make Two Ground and One Positive Mic Wire.

Look at the Subaru Bluetooth Connector picture and instruction pics above.

Looking at the back of the radio at the connector the pins go from left to right.

1 2 3 4 5
G OO G P

G = Ground O = Open P = Positive

I used the gold Pins from the Radio Shack connector on the ends of the Mic wires so that way they would slide over the Pins in the connector on the back of the radio since I did not have the actual connector to plug into the radio. I would rather make a cheap $12.00 connection then pay $198 for the actual Subaru Part.

Once you make these connections then the Bluetooth Phone options will show up on the radio.

I have setup my bluetooth phone and use it all the time now. I ran the Mic wire down the Driver side from the visor in the Window Column for the airbag. Just pop out the AIRBAG TAG and remove bolt. The cover comes right off.

Happy Bluetoothing!!
Just completed this in New Zealand on a JDM/Japanese Import Impreza, seems to work well after initial install. Kenwood FXHD07JGF2 is the HU model number, seems to be identical to the US model apart from the Japanese writing. After some Google Translate it is all go! Just wish it would stream audio/Spotify....

Thanks for the guide, was about to give up trying to find a solution!
stotty5 is offline   Reply With Quote
Old 07-23-2019, 10:53 AM   #1016
m5gorrf
Scooby Newbie
 
Member#: 468210
Join Date: May 2017
Chapter/Region: BAIC
Location: Calif foothills
Vehicle:
2006 WRX Wagon
Blue

Default

Hoping this thread is still monitored.

On the 06 Subwoofer T harness there is a additional 8 pin black connector with one jumper and two leads.

Can anyone tell me what this does?

I am considering changing the P-133 for a C-124 from an 07

No one breaks in for a stock H/U

UPDATE

found this post & solved

https://forums.nasioc.com/forums/sho...0#post13335030

Last edited by m5gorrf; 07-23-2019 at 11:37 AM.
m5gorrf is offline   Reply With Quote
Old 07-28-2019, 11:56 AM   #1017
lsWRX
Scooby Newbie
 
Member#: 375267
Join Date: Dec 2013
Chapter/Region: NESIC
Default

Will updating the grace note database on a '18 WRX stock radio add apple car play like the '19 WRX has?
lsWRX is offline   Reply With Quote
Old 07-28-2019, 01:46 PM   #1018
YungBoba
Scooby Specialist
 
Member#: 450808
Join Date: Jul 2016
Chapter/Region: SCIC
Vehicle:
2017 WRX Premium
WR Blue Pearl

Default

Quote:
Originally Posted by lsWRX View Post
Will updating the grace note database on a '18 WRX stock radio add apple car play like the '19 WRX has?
No, it's a completely different headunit. You need to swap a 2019+ headunit in or go aftermarket if you want Apple CarPlay.
YungBoba is offline   Reply With Quote
Old 07-30-2019, 10:07 PM   #1019
sub_sifu
Scooby Newbie
 
Member#: 301690
Join Date: Nov 2011
Location: Indiana
Vehicle:
2002 Wrx

Default

I tried search. This thread is a cluster. Now that it's 2019, anyone able to provide insight on a later model subarus that have a standard double din size that will physically fit into a 04-07 impreza wrx dash?

I know there are wiring harnesses out there that can take care of most of the rest.
sub_sifu is offline   Reply With Quote
Old 07-31-2019, 09:51 AM   #1020
BigWrecKs
Scooby Newbie
 
Member#: 93830
Join Date: Aug 2005
Chapter/Region: South East
Location: Flori:derp:
Vehicle:
'06 Silverado
'19 STI

Default

Will our headunits receive the recently released Android Auto update?

2019 sti
BigWrecKs is offline   Reply With Quote
Old 07-31-2019, 11:21 AM   #1021
LouCioccio
Scooby Newbie
 
Member#: 496163
Join Date: Jan 2019
Location: Erie, PA
Vehicle:
2018 Forester
Pearl White

Default

Although I don’t use AA but CarPlay this is what I found as I usually get beta version of several OS’s (win10, Macs Catalina, iOS’s). The CarPlay interface changed from using iOS 12 to 13 in layout and features. I am assuming that AA will do the same on the phone when it is updated. I did upgrade the 7” infotainment to a kenwood 9904s using the info on this site.
LouCioccio is offline   Reply With Quote
Old 10-24-2019, 12:29 PM   #1022
bovaloe
Scooby Newbie
 
Member#: 507702
Join Date: Oct 2019
Default

Trying to figure out an intermittent issue with my wife's car. 2010 Impreza, stock as stock can be

Every once in awhile,no pattern that I can figure out, the stock radio and dash clock/MPG display unit will not turn on with the car. Both displays will be blank. Shutting off and restarting usually fixes the issue, sometimes it takes a couple restarts. The memory is not affected, clock is right and presets are still loaded. As far as I know, all the interior lights and other KOER stuff is working like it should, seeming to rule out an ignition switch problem.

I have searched and the closest thing I have found is just relating to the clock, with a bad solder point, but that usually was accompanied by the clock resetting, nothing including the radio. The fact that its not a regular thing is making it a little difficult to figure out.

Has anyone run into a problem like this? Short of tearing it apart and looking to see if anything looks out of place, what should I check?
bovaloe is offline   Reply With Quote
Old 12-10-2019, 02:42 PM   #1023
GoFrogs
Scooby Newbie
 
Member#: 507317
Join Date: Oct 2019
Chapter/Region: MAIC
Location: SW Ohio
Vehicle:
2019 WRX
Pure Red

Default

Quote:
Originally Posted by sub_sifu View Post
I tried search. This thread is a cluster. Now that it's 2019, anyone able to provide insight on a later model subarus that have a standard double din size that will physically fit into a 04-07 impreza wrx dash?

I know there are wiring harnesses out there that can take care of most of the rest.

Agree. a 10yo thread does absolutely no one any good. These forums need to be broken down even more either by MY groupings or chassis designator as then people can look for items specifically related to their car/chassis code.

I'm here for just a simple (speaker) wiring diagram/pin-out for the 2019 6.5" Starlink found in the base model WRX. It is like trying to find a penny on a soccer field and not knowing where that penny actually is -- lots and lots of (creative) searching required.

Subaru has more audio configurations and combos than VW/Audi and it can be a real mess trying to find items in all of these child forums.

Example - why are Interior and Exterior modifications combined? Each is a different area of the car and needs to/should be their own separate forums.

Same goes for lighting and electrical/car audio...different areas/topics, different forums; not crammed in the same one. [/rant over]
GoFrogs is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Stock head unit information -- pin-outs, aux inputs, and more SVXdc Car Audio, Video & Security 12 01-23-2007 03:27 AM
Question about factory head units nsnguyen Car Audio, Video & Security 7 04-30-2004 03:26 PM
Question about using head unit to power back speakers STI-o-MY Car Audio, Video & Security 0 12-01-2003 04:06 PM
question about my head unit creature546 Car Audio, Video & Security 1 10-03-2002 08:48 PM

All times are GMT -4. The time now is 01:56 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.