Welcome to the North American Subaru Impreza Owners Club Wednesday January 29, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Reviews > Vendor Reviews

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-12-2020, 05:26 PM   #1
boostedGS
Scooby Newbie
Member Sales Rating: (2)
 
Member#: 303842
Join Date: Dec 2011
Location: SGV/E. Los Angeles
Default BEWARE: Bulletproof Automotive in Hawthorne, CA

BEWARE: Horrible Customer Service, Damaged Wheels.



I just wanted to share my last experience with Bulletproof Automotive in Hawthorne, CA. On or about 9/26/19 I dropped off my RCF to get my headers and exhaust taken off. When I dropped off my car, I had just installed brand new 20" Work Meister S1Rs with gloss anodized bronze lips/barrels and gloss faces. My car has never seen rain since I bought my car new, it always garage kept, and doesn't have 1 single scratch on the car. Currently, car only has 11,800 miles and I bought the car back in ~April 2015. When I dropped it off, I dropped it off with David, one of their sales guys and/or manager. I told him I'm anal about my car and it's taken really good care of it, it's 100% garage kept, rarely gets driven, it has no scratches, just put on brand new wheels, etc., so I requested a walk-thru inspection of my car. Myself and David both did an inspection, and after I was about to leave, my friend and I watched him do another full walk-around of the car before heading into the office. While my car was there for over 2 months, at one point, Avi (one of the owners) told me they had to move my car to their other location, but don't worry because it will be "safe".



Fast forward, I didn't get my car back until 12/7/19 (OVER 2 MONTHS for a header/exhaust install back to my stock parts!). Anyway, I'm sure they lagged on my car to finish whatever they had to do for SEMA 2019 and Avi (one of the owners) charged me a fraction of the cost to do the job from the initial cost to install my Novel exhaust and headers. Avi mentioned the headers/exhaust job is a 10-12 hour job, so it takes a really long time and it's a PITA. So with SEMA and not making much profit from my vehicle's work order, I can see why he lagged it, but this is still no excuse. (They also did not mention any lag because of SEMA 2019, I just assume this because they do SEMA every year). Horrible customer service. While this time and delay, I was never notified about status. I was the one that had to reach out once every couple weeks to get a response, if I hadn't contacted them, I would be waiting forever. I was about to leave the country for almost a month mid December 2019, so I contacted David again during mid-1st week of December 2019, I told them my situation and I did not want my car to sit there for ANOTHER month and they need to get it done. I called on Wednesday 12/4, and they said they will schedule my car to be worked on Friday morning, 12/6/19. Friday afternoon around 5/6pm, I was told my car is ready and told me it's ready for pick up the next day, Saturday 12/7/19.



When I arrived to pick it up, it was dirty since it was sitting in the on/off rain, ready to be driven home. I did an inspection of my car when I picked it up. I looked for the obvious dents, dings, and curb rashes. I also checked for exhaust leaks since they did exhaust repair. After this, I drove it home and parked it in my garage where it usually stays. Once the weather cleared up and I had some time, on Wednesday 12/11/19, I washed my car down and while drying my car, I noticed HALF of my wheel coatings on BOTH my rear wheels were missing. The gloss bronze metallic finish from Work Wheels was gone, and you can see lot of fine scratches on the raw metal. It looks like someone spilled something corrosive and tried to wipe it off.



I contacted Avi and David and told them the situation. They both denied that it was them, and that was that. Communication ends. I contacted the other owner Ben Schaeffer, via IG, and he read my messages, but did not reply. When I called Avi, all he could say was my car was parked in a safe location and I asked where, and he said, "OUTSIDE ON THE SIDE OF OUR BUILDING". ARE YOU SERIOUS? After I told those guys how anal I am about taking care of my car, and the condition it WAS in when I dropped it off, this is how they take "care" of my car in a "safe" location. So my car was sitting outside for over 2 months, getting sun damage to my paint, leather seats, etc.



Avi and David said their techs did not damage my wheels. Okay. But it could have been ANYONE else in that area, especially if my car was parked outside for over 9 weeks. My car was under their care for 9-10 weeks and my wheels were damaged at some point. They should take care of this situation instead of just brushing it off and not replying to my messages or concern besides saying, "it wasn't us". Their other location is a detailing garage, perhaps, since my car was sitting for so long, they tried to detail the car and damaged the wheels with their cleaners. This is also another high possibility. Either way, they are not taking responsibility for this damage while under their care for nearly 10 weeks.


:shakes head::shakes head::shakes head:









* Registered users of the site do not see these ads.
boostedGS is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:15 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.