Welcome to the North American Subaru Impreza Owners Club Saturday August 24, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-11-2019, 09:23 AM   #1
NoobSub2007
Scooby Newbie
 
Member#: 505164
Join Date: Aug 2019
Default 2007 Impreza- wire dilema

Good day everyone.
I promise i have searched and searched again. Since i don't know the name of this device, I'm asking for your help. This is my first Subaru so things are different for me.
In working on replacing the factory speakers. Mine are all 4 in the doors but in the trunk there's space for 2 more 6x9. The problem is that one of the holes has this little box in it. To me it looks like a crossover as it has 2 coils and 2 caps from what i can see. It has a black and red wire going in and black and red going out. The plug looks like the one on the speaker with a t formation.
I would appreciate any insight in what this might be. I do not have the sub under the chair or in the trunk.

https://1drv.ms/u/s!AmBPTyG-MkqXnKQ7DcwOHRFCDkeCjg

Thank you.

Ps: not sure if I'm sharing the picture correctly as it does not show up.
* Registered users of the site do not see these ads.

Last edited by NoobSub2007; 08-11-2019 at 02:50 PM. Reason: Edited to clarify picture status
NoobSub2007 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-11-2019, 08:49 PM   #2
thatgarrett
Scooby Newbie
 
Member#: 497099
Join Date: Jan 2019
Location: TN
Vehicle:
2007 Outback Sport
Urban Gray

Default

I have a wagon so I canít match it up exactly, but Iím pretty sure thatís the radio antenna booster for the OEM radio and is required to get reception. Itís what the power control wire coming from the HU activates, equivalent to raising the antenna in an older car
thatgarrett is offline   Reply With Quote
Old 08-14-2019, 07:59 AM   #3
NoobSub2007
Scooby Newbie
 
Member#: 505164
Join Date: Aug 2019
Default

Thank you sir. You pointed me in the right direction. It is actually the noise suppression for the glass antenna. I found it on the diagram.
I appreciate your advice.



Quote:
Originally Posted by thatgarrett View Post
I have a wagon so I canít match it up exactly, but Iím pretty sure thatís the radio antenna booster for the OEM radio and is required to get reception. Itís what the power control wire coming from the HU activates, equivalent to raising the antenna in an older car
NoobSub2007 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 09:07 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.