Welcome to the North American Subaru Impreza Owners Club Saturday October 21, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-10-2017, 10:25 PM   #1
Subi89
Scooby Newbie
 
Member#: 475857
Join Date: Oct 2017
Default 08 Impreza with Cat issues.

Hi all! I have an 08 Impreza with 128000 mi that was given to me by a friend who was moving overseas and didn't want to deal with it. But as the saying goes "you get what you pay for" it has an aftermarket Catalytic Converter that the ECS doesn't recognize and keeps burning out O2 sensors and she has some issues. I took it to a mechanic for a full inspection and got the following codes.
P0137- O2 sensor circuit low voltage(bank1 sensor2)
P2096- Post Catalyst furl trim system too lean (Bank 1)
P0140- O2 sensor circuit range/performance(Bank1 snesor2)

I'm assuming these are all caused by the faulty Cat. The car is severely underpowered when accelerating and I cant get to go over 65MPH, it also won't shift into 5th even with manual mode engaged. I've already budgeted for a new timing belt kit I can do myself. my question is, If I were to replace the entire exhaust system, pipes, CAT, Muffler(has a crack anyway), and 02 sensor should that fix the problem? money is a little tight and I cant really afford to go replacing every part until it's fixed and I honestly can't really afford for a mechanic to look at it at the moment so I'm really hoping someone here can help me out. thanks in advance!!!
* Registered users of the site do not see these ads.
Subi89 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-13-2017, 09:44 AM   #2
Charlie-III
NASIOC Supporter
 
Member#: 30669
Join Date: Dec 2002
Chapter/Region: Tri-State
Location: USA, North NJ, 07456
Vehicle:
1998 Legacy 2.5GT
Silver Sleeper BK, 5MT

Default

Cross posting is frowned upon.

Quite a few answers here......https://forums.nasioc.com/forums/sho....php?t=2855394
Charlie-III is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:25 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.