Welcome to the North American Subaru Impreza Owners Club Thursday April 27, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-10-2017, 12:56 PM   #1
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default Swapping out HVAC dash module on early ('93-96) dash

I've got a '96 Brighton coupe. The center knob on the HVAC doesn't work; previous owner told me the clip that holds the operating cable in place broke. For now, the cable is just sticking out through the top of the center stack, and I can operate it manually. You can see I've got nothing in the top DIN location to allow access to that cable



So, I've sourced a new HVAC unit from the junkyard, but I'm at a loss on how you actually go about removing / reinstalling those control cables where they attach to the knobs. When I pulled the one out of the junkyard car I ended up just cutting the cables off. There's a little C-clip that holds the cable in place - I can pull that clip out to give the cable some freedom of movement. But that doesn't give me enough slack in the cable to work the end of it free from where it connects to the knob.

What trick am I missing here? Thanks!
* Registered users of the site do not see these ads.
Patrick Olsen is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-28-2017, 12:33 PM   #2
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

I swapped out the HVAC units a week or so ago. I couldn't get enough slack to connect the two control cables to the head unit, so I disconnected them at the other end (under the dash), hooked them to the head unit, installed the head unit, then re-connected the cables under the dash.

Both cables are pretty easy to get to - they're on either side of the transmission hump under the dash. If you kneel outside the car and lean into the footwells through each front door, you can get to the cables.

I suppose the one thing to watch out for is to ensure the knobs on the head unit and the dampers the cables attach to are in the correct positions before you re-connect the cables under the dash.
Patrick Olsen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 05:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.