Welcome to the North American Subaru Impreza Owners Club Saturday May 26, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-05-2012, 11:12 AM   #1
4Birdman
Scooby Newbie
 
Member#: 315804
Join Date: Apr 2012
Chapter/Region: South East
Location: Raleigh, NC
Vehicle:
2003 WRX
Black

Default P0301, P0302, P0420 codes - 2003 Outback

I've got a deal worked on a 2003 Outback with the 2.5L. It has 141k miles, new tune up, water pump, timing belt, etc. In good shape and runs good. Mostly.

The problem is that the CEL is flashing and I'm getting a P0301, P0302, and P0420 code. The car starts and idles fine and runs good when on the highway, but when you get in to it it bucks and is down on power.

I'm thinking it is the coil, since it is a 1&2 cylinder misfire and those are fired off of the same pack.

What do you guys think?
* Registered users of the site do not see these ads.
4Birdman is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-05-2012, 06:58 PM   #2
mod maniac
Scooby Specialist
 
Member#: 300551
Join Date: Nov 2011
Chapter/Region: SCIC
Location: mariposa ca.
Vehicle:
2002 FOZ STI 2.34
Fullers Garage

Default

It could be the coil pack, it could be a hg, it could be plugs. do a compression test when you check the plugs.
mod maniac is offline   Reply With Quote
Old 04-05-2012, 10:06 PM   #3
GrundleJuice
Scooby Specialist
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: Central Floriderp
Default

Sounds fuel related. Could be a sensor problem or an intake or pre cat exhaust leak. Try resetting the ecu and see if it helps in the short term. If it "fixes" it for a few miles, but the problem comes back then it's probably something I mentioned

Last edited by GrundleJuice; 04-05-2012 at 10:11 PM.
GrundleJuice is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
p0420 code - 2008 WRX Trelor Open Source Reflashes 3 08-27-2011 12:40 AM
Yet another p0420 code - 2002 Outback 2.5l merlin2375 Service & Maintenance 3 07-13-2010 10:26 PM
cel p0301,p0302 pending code ben c Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 11 01-24-2009 06:45 PM
cel codes p0301 and p0420 hagood22 Newbies & FAQs 0 04-17-2008 09:14 PM
Misfires- P0301 P0302 P0303 P0304 AndyHidley Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 11-30-2001 01:18 AM

All times are GMT -4. The time now is 12:32 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.