Welcome to the North American Subaru Impreza Owners Club Wednesday April 26, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-13-2012, 02:05 PM   #1
kaleonearth
Scooby Newbie
 
Member#: 274436
Join Date: Feb 2011
Chapter/Region: South East
Location: Tampa, FL
Vehicle:
2011 STI
Unobtanium Grey

Default Timing Check Question

So random question.. I think my car may have jumped timing or have thrown a rod bearing... Regardless, I'm checking the timing before building a block and throwing it in.

Can I re-adjust my timing and use the same belt for testing? Would there be any consequences to doing this? If this happens to fix my issue then I'm replacing the set but I don't want to spend 270ish for the kit just yet in the case that I've got to buy a block to start new.

Maybe it's a stupid question, I just like to cover all my bases.

Thanks guys/gals.
* Registered users of the site do not see these ads.
kaleonearth is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
('06-'07) First time Member, First time Owner, Questions! Fade2black02 Impreza Forum 3 02-14-2012 11:25 PM
[email protected] on ej205 & vf30 in a gc8**edit new best time** check last post!! julien Proven Power Bragging 57 05-12-2010 11:21 AM
CC Fraud AGAIN. BLIZZARD-ENT this time... check your records... Idjiit Off-Topic 34 08-31-2007 10:08 AM
Hello all Newbie to Subbies...First Time Check in happy187 Texas Impreza Club Forum -- TXIC 42 08-09-2006 09:56 PM
long time listener, first time caller-computer question Anna Off-Topic 8 04-13-2006 08:25 PM

All times are GMT -4. The time now is 02:00 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.