Welcome to the North American Subaru Impreza Owners Club Saturday March 25, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-12-2012, 05:24 PM   #1
Frank-i-e
Scooby Specialist
 
Member#: 316463
Join Date: Apr 2012
Location: Houston, Texas
Vehicle:
2005 STi
World Rally Blue

Default Brake lights Stay on, no cruise control

Hey guys, so I'm having an issue. Like the title says ill drive my car and by the end of the drive and turn off my car my brake lights will be on. All 3 on the bottom row remain on even when shutting off the car. The only way I can get them to turn off is by pumping the brake when the car is already off.

Also with this issue my cruise control is not working. Assuming it detects that my brakes a depressed for some reason.

I have looked at this thread but sadly didn't fix my issue even replacing my bulbs. I didn't unplug the tail lights yet though.

http://forums.nasioc.com/forums/show...2365294&page=2

Thanks guys


FIXED: Brake light switch was the culprit.
* Registered users of the site do not see these ads.

Last edited by Frank-i-e; 08-17-2012 at 10:06 PM.
Frank-i-e is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-12-2012, 06:04 PM   #2
leftbraned
Scooby Newbie
 
Member#: 173364
Join Date: Mar 2008
Location: N. Detroit
Vehicle:
2003 wrx

Default

sounds like your brake light switch is going bad. Its under the dash and your brake pedal pushes it in. If its not getting pushed in all the way your cruise thinks you're using brakes and won't stay engaged and your brake lights will remain on even with the car off.

easy fix!
leftbraned is offline   Reply With Quote
Old 08-12-2012, 07:09 PM   #3
Frank-i-e
Scooby Specialist
 
Member#: 316463
Join Date: Apr 2012
Location: Houston, Texas
Vehicle:
2005 STi
World Rally Blue

Default

That's exactly what I was thinking but after reading that thread, I thought I may be a victim of some gremlins. Lol I'll have to order a switch here soon. I work at autozone and they can't get it, junk.
Frank-i-e is offline   Reply With Quote
Old 08-13-2012, 01:15 AM   #4
Cougar4
Scooby Guru
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

Check the adjustments for the brake switch and cruise control on the brake pedal. That will most likely take care of the trouble. There may be a weak return spring on the pedal also.
Cougar4 is offline   Reply With Quote
Old 08-13-2012, 04:48 AM   #5
Frank-i-e
Scooby Specialist
 
Member#: 316463
Join Date: Apr 2012
Location: Houston, Texas
Vehicle:
2005 STi
World Rally Blue

Default

Quote:
Originally Posted by Cougar4
Check the adjustments for the brake switch and cruise control on the brake pedal. That will most likely take care of the trouble. There may be a weak return spring on the pedal also.
Hey bud, I actually got down there and took a look and the previous owner has a bunch of wires and what not from the viper alarm, the audio and who knows what. Looks like the wiring was pulled some how and broke the switch in half. I tried getting in there and giving the pig tail some more room but I finished breaking the brake switch. It's the switch for sure, just need to find one.

Thanks everyone for the prompt responses!

I wish I knew what the heck he has going down there and clean it up but looks like a huge mess that if I mess up, I won't be able to make work. Lol
Frank-i-e is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 09:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.