Welcome to the North American Subaru Impreza Owners Club Saturday March 25, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 02-12-2017, 08:23 AM   #1
Rockin Ronnie
Scooby Newbie
 
Member#: 37890
Join Date: Jun 2003
Chapter/Region: E. Canada
Vehicle:
2009 Forester
Dark Grey Metallic

Question 09 Cruise Control light flashing only

This has happened several times and in each case there is NO CEL light.

When I start the car, get on the highway I can set the Cruise but after about 20 minutes or so it begins to flash and will keep flashing until I stop the car and restart it and then the same thing occurs, on for 20-30 minutes or so and then begins flashing. Does not seem to matter if it is dry or wet out.

I also notice that when the cruise is on there appears to be a slight hesitation or pulsing that is barely noticeable but it is there.

Took it to the dealer twice and they could find nothing. They said bring it in when it is flashing and keep it running while we check it. Trouble is, the dealer is 35 minutes away. Someone also suggested bringing it into any auto parts supplier who can check the codes.

Is this an ignition wire issue?

2.5l Impreza sedan with 110,000 kilometers, 7 1/2 years old and never any ignition components replaced.

Ron
* Registered users of the site do not see these ads.
Rockin Ronnie is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-12-2017, 11:22 PM   #2
CosmoTheCat
Scooby Newbie
 
Member#: 3409
Join Date: Jan 2001
Chapter/Region: NWIC
Location: Oly
Vehicle:
98 My FMIC
Is bigger than yours.

Default

You've never done spark plugs?

Does the CEL prove out when you turn the key on?


You need to check the cancel codes to see why it's shutting off. The auto parts store cannot do this. Shutting the ignition off can clear cancel codes, so get it to fail and take it in. Not a great answer, but there are a bunch of things it could be.
CosmoTheCat is offline   Reply With Quote
Old 02-18-2017, 12:24 PM   #3
Rockin Ronnie
Scooby Newbie
 
Member#: 37890
Join Date: Jun 2003
Chapter/Region: E. Canada
Vehicle:
2009 Forester
Dark Grey Metallic

Default

No, plugs have never been done. Could be an issue?

Ron
Rockin Ronnie is offline   Reply With Quote
Old 02-18-2017, 12:29 PM   #4
drpoop
Scooby Specialist
 
Member#: 421858
Join Date: May 2015
Default

You definitely need to replace the spark plugs. I don't know that it would cause the issue, but just go ahead and do that right now anyway.
drpoop is offline   Reply With Quote
Old 03-08-2017, 06:44 AM   #5
Rockin Ronnie
Scooby Newbie
 
Member#: 37890
Join Date: Jun 2003
Chapter/Region: E. Canada
Vehicle:
2009 Forester
Dark Grey Metallic

Default

Also getting some almost imperceptible pulsing and surging when cruise is engaged. Cruise then flashes after about 10-15 minute of driving.

Ron
Rockin Ronnie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.