Welcome to the North American Subaru Impreza Owners Club Monday November 28, 2022
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 09-27-2013, 08:43 PM   #1
kbobomber89
Scooby Newbie
 
Member#: 231418
Join Date: Nov 2009
Location: Kennesaw, GA
Vehicle:
2006 WRX

Default how bad is the gates water pump?

i drive an 06 wrx with 83,000 miles on it. i have a ticking coming from the timing cover and figured it wouldnt hurt to do a timing belt job anyway. well i have all my parts ordered for the job and was doing some research on the water pump. didnt find the answer i was looking for. some people said they just left the water pump on the car and didnt use the gates water pump. i know the impeller is a little different and the oem one is probably better, but how bad is the gates pump? my water pump isnt leaking or anything and i dont think its causing the ticking im hearing so would it be an issue to leave it on and just change everything else? i have a new subaru thermotstat and subaru gasket to put it.
* Registered users of the site do not see these ads.
kbobomber89 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-27-2013, 08:47 PM   #2
2011WRXMT
Scooby Specialist
 
Member#: 270426
Join Date: Jan 2011
Chapter/Region: NWIC
Location: Belgrade Montana
Vehicle:
2011 WRX Premium
Satin Pearl White

Default

The gates pump is fine. I just did the timing belt in my 02 a few months ago with the gates kit. I would highly recommend doing the water pump while you have everything apart even though it isn't leaking. Mine want leaking and I replaced it anyway. How ****ty would it be if you did all that work and then the water pump you didn't change starts leaking and what not and then you have to take **** apart again. If your worried about the gates water pump get an oem one from Subaru?
2011WRXMT is offline   Reply With Quote
Old 09-27-2013, 08:53 PM   #3
vision.dynamix
Scooby Guru
 
Member#: 139955
Join Date: Feb 2007
Chapter/Region: NESIC
Location: Boston
Vehicle:
2015 Subaru STI
17Forester / 18Crosstrek

Default

Quality component.

And definitely do all the pulleys, tensioner and water pump while youre doing the timing belt. Do the thermostat also.
vision.dynamix is offline   Reply With Quote
Old 09-27-2013, 09:20 PM   #4
kbobomber89
Scooby Newbie
 
Member#: 231418
Join Date: Nov 2009
Location: Kennesaw, GA
Vehicle:
2006 WRX

Default

Yep got a Subaru thermostat, coolant, and gaskets.
kbobomber89 is offline   Reply With Quote
Old 09-27-2013, 10:56 PM   #5
EdHilario
Scooby Guru
 
Member#: 137398
Join Date: Jan 2007
Chapter/Region: E. Canada
Location: Toronto
Vehicle:
2004 Impreza

Default

It's not necessarily "bad" at all. Also taking into consideration that Gates makes Subaru's belts (timing and accessory belts).
EdHilario is offline   Reply With Quote
Old 09-27-2013, 11:06 PM   #6
Back Road Runner
Scooby Guru
 
Member#: 60082
Join Date: Apr 2004
Chapter/Region: MWSOC
Location: Minnesota
Vehicle:
2004 Forester STI
Silver

Default

Gates complete kit at Rockauto.com, $210 to $230 depending on belt choice:

http://www.rockauto.com/catalog/more...578&cc=1432597
Back Road Runner is offline   Reply With Quote
Old 09-28-2013, 10:17 AM   #7
Unabomber
👏 Big Ron 👏
Moderator
 
Member#: 18062
Join Date: Apr 2002
Chapter/Region: MAIC
Location: I can save you a ton of cash
Vehicle:
on car parts so PM
me b4 j00 buy

Default

And know that you are doing it early to satisfy your OCD needs. Doing it early is a waste of time, money, and resource as it is designed on a 105,000 mile cycle. And don't use a ticking sound as an excuse either....our cars are damn sewing machines and ticking is what they do.
Unabomber is offline   Reply With Quote
Old 09-28-2013, 10:40 AM   #8
[email protected]
Former Vendor
 
Member#: 301037
Join Date: Nov 2011
Chapter/Region: MWSOC
Location: Minneapolis, MN
Vehicle:
2004 Forester XT
Aspen White

Default

Quote:
Originally Posted by Unabomber View Post
And know that you are doing it early to satisfy your OCD needs. Doing it early is a waste of time, money, and resource as it is designed on a 105,000 mile cycle. And don't use a ticking sound as an excuse either....our cars are damn sewing machines and ticking is what they do.
^These are words of wisdom. If you are worried about the condition of the belt you could visually inspect it by pulling the front covers off.
art@grimmspeed is offline   Reply With Quote
Old 09-28-2013, 11:39 AM   #9
MorganaMotorsports
Former Vendor
 
Member#: 357887
Join Date: May 2013
Location: Tri-State
Vehicle:
2013 WRX
Morganamotorsports.com

Default

The Gates waterpump is good, we use their kits all the time without any problems at all.
MorganaMotorsports is offline   Reply With Quote
Old 09-29-2013, 11:21 AM   #10
kbobomber89
Scooby Newbie
 
Member#: 231418
Join Date: Nov 2009
Location: Kennesaw, GA
Vehicle:
2006 WRX

Default

I did get my belt kit from rock auto. Couldn't beat that price. I've owned a wrx before this one and it did not make this noise. I am positive it's coming from the timing covers. I completely agree I'm doing it too early but this makes me feel better to just go ahead and get it done. Don't see the harm in it.
kbobomber89 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 02:21 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2022 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.