Welcome to the North American Subaru Impreza Owners Club Monday January 23, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-23-2016, 10:41 PM   #1
dan_drive_good
Scooby Newbie
 
Member#: 406961
Join Date: Nov 2014
Chapter/Region: NESIC
Vehicle:
2011 WRX hatch

Default Reoccurring Problems 2015-17 STI

I've had the pleasure of getting to know 2 separate 2015 STI's with 30k on them, both of which experienced a multitude of engine problems (misfiring cylinders, slipped belts, broken cam sockets) and leaking rear differentials.

Are there reoccurring drivetrain/powertrain issues with the 2015-17 STI's? Who else has experience with these issues?
* Registered users of the site do not see these ads.
dan_drive_good is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-23-2016, 11:15 PM   #2
drpoop
Scooby Specialist
 
Member#: 421858
Join Date: May 2015
Default

Sounds like you had bad luck more than anything. Or you beat the hell out of your car and expect it to be fine (just sayin')
drpoop is online now   Reply With Quote
Old 12-25-2016, 05:54 PM   #3
seetrix
Scooby Newbie
 
Member#: 460249
Join Date: Dec 2016
Location: South Australia
Vehicle:
2001 Gda
White

Default

Running to much boost?
seetrix is offline   Reply With Quote
Old 12-28-2016, 08:55 PM   #4
dan_drive_good
Scooby Newbie
 
Member#: 406961
Join Date: Nov 2014
Chapter/Region: NESIC
Vehicle:
2011 WRX hatch

Default

I was not the cause of the problems with these cars; their previous owners were. God knows what you have to do to an STI in 30k miles to do that kind of damage.

They were both bone stock as far as I know. They could have had components removed prior to trade-in, but I saw no signs or remnants of modifications.
dan_drive_good is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 02:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.