Welcome to the North American Subaru Impreza Owners Club Tuesday January 24, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-04-2002, 02:42 PM   #1
ScoobieSnaX
Scooby Specialist
 
Member#: 10844
Join Date: Oct 2001
Location: location, location...
Vehicle:
2004 Acura TL Navi
Pearl

Talking UTECLogger 1.0.9 RELEASED!

Greetings,

I have completed the first version of the UTECLogger software and would appreciate any feedback or comments you may have. The current release incorporates the following features:

-Map create/edit, open & save
-Datalog view (All datalogs 1-6 are viewable)
-Maximum ignition advance limitation
-Detonation detection and flagging

This first release is provided FREE of charge and will work with UTEC map files from firmware versions 2.2b and older. Please consult the readme.txt for bug info. and updates. The next major release is expected at the end of December and will include minor UTEC connectivity.

To download version 1.0.9, visit: http://24.79.147.167/utec/uteclogger109.zip


Regards,

Jason Shave (ScoobieSnaX)
UTECLogger
PSI Consulting Services
* Registered users of the site do not see these ads.

Last edited by ScoobieSnaX; 11-18-2002 at 01:33 PM.
ScoobieSnaX is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-04-2002, 02:50 PM   #2
easternwrx
Scooby Newbie
 
Member#: 28588
Join Date: Nov 2002
Location: Edmonton
Vehicle:
2003 WRX Wagon
Yellow

Default

As soon as my UTEC shows up I will be giving it a try.
easternwrx is offline   Reply With Quote
Old 11-04-2002, 03:36 PM   #3
davidm_sh
Scooby Specialist
 
Member#: 5994
Join Date: Apr 2001
Location: Fort Collins, CO
Vehicle:
2004 Impreza WRX STi
Java Black

Default Re: UTECLogger 1.0.9 RELEASED!

Quote:
Originally posted by ScoobieSnaX

This first release is provided FREE of charge and will work with UTEC map files from firmware versions 2.2c and older.
COOL-

thanks for the logger I will try it out shortly here. I do have one question however. You mentioned you need UTEC firmware 2.2c? I think/thought that the current firmware (public release) is 2.2a with 2.2b being closed loop boost control +??? But I have no idea on what or when 2.2c would be?

Thanks
davidm_sh is offline   Reply With Quote
Old 11-04-2002, 03:58 PM   #4
nmyeti
Scooby Specialist
 
Member#: 4980
Join Date: Mar 2001
Location: Albuquerque, NM USA
Default Re: Re: UTECLogger 1.0.9 RELEASED!

Quote:
Originally posted by davidm_sh


COOL-

thanks for the logger I will try it out shortly here. I do have one question however. You mentioned you need UTEC firmware 2.2c? I think/thought that the current firmware (public release) is 2.2a with 2.2b being closed loop boost control +??? But I have no idea on what or when 2.2c would be?

Thanks
2.2c is closed loop with RPM and TPS control

This was a Bata-test only build, and what we learned from it was put into 2.2d and 2.2e which were also Bata-test builds. We had 2.3 ready to go, but decided to add a few other changes to it, and will be sending out 2.4 once it passes the Bata-test period… more on this after SEMA.

-Nathan
nmyeti is offline   Reply With Quote
Old 11-04-2002, 04:16 PM   #5
2000vfr800
Scooby Specialist
 
Member#: 15599
Join Date: Feb 2002
Chapter/Region: MWSOC
Location: Livonia, MI
Default

OK...so...will the UTECLogger 1.0.9 work with 2.2b?
2000vfr800 is offline   Reply With Quote
Old 11-04-2002, 04:21 PM   #6
ScoobieSnaX
Scooby Specialist
 
Member#: 10844
Join Date: Oct 2001
Location: location, location...
Vehicle:
2004 Acura TL Navi
Pearl

Default

My mistake, 2.2b and older are supported.
ScoobieSnaX is offline   Reply With Quote
Old 11-04-2002, 04:25 PM   #7
ScoobieSnaX
Scooby Specialist
 
Member#: 10844
Join Date: Oct 2001
Location: location, location...
Vehicle:
2004 Acura TL Navi
Pearl

Default

I found a bug the other night which didn't make it into the zip file.

The detonation flag works by comparing the timing of the previous line to the current one. If the difference is greater than the option set in "Tools/Options", it will be flagged. However, if "ECU" preceeds the detonation, all "ECU" values are flagged as DET.

This has been fixed in the next release which is due out later this week.
ScoobieSnaX is offline   Reply With Quote
Old 11-04-2002, 04:35 PM   #8
gossamer_monster
Scooby Specialist
 
Member#: 3574
Join Date: Jan 2001
Chapter/Region: NESIC
Vehicle:
2002 WRX
Blase' Yellow----R.I.P.

Default Re: Re: Re: UTECLogger 1.0.9 RELEASED!

Quote:
Originally posted by nmyeti


2.2c is closed loop with RPM and TPS control

This was a Bata-test only build, and what we learned from it was put into 2.2d and 2.2e which were also Bata-test builds. We had 2.3 ready to go, but decided to add a few other changes to it, and will be sending out 2.4 once it passes the Bata-test period… more on this after SEMA.

-Nathan
Very cool.
Can`t wait.

Bill
gossamer_monster is offline   Reply With Quote
Old 11-04-2002, 09:28 PM   #9
crazyhorse
Scooby Guru
 
Member#: 19502
Join Date: Jun 2002
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
2010 Impreza with no
scoop. =(

Default

Now why oh why isn't it on my downloads page at wrxhackers. I feel neglected. Sent you a PM about some info.
crazyhorse is offline   Reply With Quote
Old 11-04-2002, 09:35 PM   #10
ScoobieSnaX
Scooby Specialist
 
Member#: 10844
Join Date: Oct 2001
Location: location, location...
Vehicle:
2004 Acura TL Navi
Pearl

Default

Should be up there in a jiffy
ScoobieSnaX is offline   Reply With Quote
Old 11-05-2002, 08:10 AM   #11
2000vfr800
Scooby Specialist
 
Member#: 15599
Join Date: Feb 2002
Chapter/Region: MWSOC
Location: Livonia, MI
Default

Nathan...

Can you elaborate a little on what kind of closed-loop scheme you are going to use for boost control? PID?
2000vfr800 is offline   Reply With Quote
Old 11-05-2002, 06:56 PM   #12
jjunior887
Scooby Specialist
 
Member#: 16738
Join Date: Mar 2002
Chapter/Region: MAIC
Location: Charles Town, WV
Vehicle:
2015 WRX Limited
CWP

Default

After editing a Map I try to save it and it causes a run time error '70' message and closes the UTEC logger without saving. How do I save my maps that I've edited? BTW it works great on my desktop just not my laptop.-James

Last edited by jjunior887; 11-05-2002 at 08:15 PM.
jjunior887 is offline   Reply With Quote
Old 11-05-2002, 08:23 PM   #13
ScoobieSnaX
Scooby Specialist
 
Member#: 10844
Join Date: Oct 2001
Location: location, location...
Vehicle:
2004 Acura TL Navi
Pearl

Default

James,

Which OS are you using on your laptop? Which area of the map are you modifying (fuel/timing/boost) and what values are you trying to use?

Thanks,

Jason
ScoobieSnaX is offline   Reply With Quote
Old 11-05-2002, 08:35 PM   #14
jjunior887
Scooby Specialist
 
Member#: 16738
Join Date: Mar 2002
Chapter/Region: MAIC
Location: Charles Town, WV
Vehicle:
2015 WRX Limited
CWP

Default

windows 98: Timing : I'm only moving them 1 or 2 from the base map. Like I said it works fine on my desktop(XP) but I'm having problems on the laptop. The other thing I noticed, whenm you use the up down arrow keys sometimes it moves the value to 25 from say 16 with just one click. It seems like it gets a certain value then sticks with it. Let me know if this makes any sense.-James
jjunior887 is offline   Reply With Quote
Old 11-05-2002, 08:45 PM   #15
ScoobieSnaX
Scooby Specialist
 
Member#: 10844
Join Date: Oct 2001
Location: location, location...
Vehicle:
2004 Acura TL Navi
Pearl

Default

Thanks. I don't have a Win98 box to test with unfortunately. The spin button values should be fixed in the next release.

If you get a chance to try it on another system let me know how it works out for you.

Thanks,

Jason
ScoobieSnaX is offline   Reply With Quote
Old 11-05-2002, 09:03 PM   #16
jjunior887
Scooby Specialist
 
Member#: 16738
Join Date: Mar 2002
Chapter/Region: MAIC
Location: Charles Town, WV
Vehicle:
2015 WRX Limited
CWP

Default

Hey Jason, I don't have a nother system with 98 on it but it worked ok with XP on my desktop. I just went ahead and did my editing on it and saved to a floppy to put it on my laptop. I was just letting you know in case it was a common problem you had already found a fix for. I'll look forward to seeing the next release when it comes out, this looks like it could be pretty promising.-James
jjunior887 is offline   Reply With Quote
Old 11-05-2002, 11:13 PM   #17
S-1
Scooby Specialist
 
Member#: 10842
Join Date: Oct 2001
Chapter/Region: MAIC
Location: NOVA
Vehicle:
07 2.5i Wagon
Black

Default

Are there less rpm points on your logger than on the utec logger provided by TXS or did I just not count right? I just downloaded it and was checking it out real quick, so I could be mistaken.

thanks for developing this BTW
S-1 is offline   Reply With Quote
Old 11-17-2002, 10:30 PM   #18
jjunior887
Scooby Specialist
 
Member#: 16738
Join Date: Mar 2002
Chapter/Region: MAIC
Location: Charles Town, WV
Vehicle:
2015 WRX Limited
CWP

Default

Quote:
Originally posted by S-1
Are there less rpm points on your logger than on the utec logger provided by TXS or did I just not count right? I just downloaded it and was checking it out real quick, so I could be mistaken.

thanks for developing this BTW
the one in the timing part screwed me up a bit, the first two rows (500 and 750) on my stage 2 map should be ECU, instead they are 35 which is supposed to be at 1000 and 1250. This throws the whole map off, I checked it. When I uploaded the map from the utec logger all the #'s were off by 2 rows. I asked a similar question about this on wrxhackers.com but havn't heard anything yet. Here is the link http://www.wrxhackers.com/modules.ph...iewtopic&t=102 -james
jjunior887 is offline   Reply With Quote
Old 11-18-2002, 12:01 PM   #19
ScoobieSnaX
Scooby Specialist
 
Member#: 10844
Join Date: Oct 2001
Location: location, location...
Vehicle:
2004 Acura TL Navi
Pearl

Default

James,

Could you send me your map file? I'll have a look and see where the error is.

Thanks,

Jason
ScoobieSnaX is offline   Reply With Quote
Old 11-18-2002, 12:15 PM   #20
ScoobieSnaX
Scooby Specialist
 
Member#: 10844
Join Date: Oct 2001
Location: location, location...
Vehicle:
2004 Acura TL Navi
Pearl

Default

Quote:
Originally posted by jjunior887

the one in the timing part screwed me up a bit, the first two rows (500 and 750) on my stage 2 map should be ECU, instead they are 35 which is supposed to be at 1000 and 1250. This throws the whole map off, I checked it. When I uploaded the map from the utec logger all the #'s were off by 2 rows. I asked a similar question about this on wrxhackers.com but havn't heard anything yet. Here is the link http://www.wrxhackers.com/modules.ph...iewtopic&t=102 -james
If you open a map file with NOTEPAD and view the first two lines, they're not used in tuning. They represent 0rpm, 250rpm. The last three lines are the same, they represent rpm points 9250, 9500, and 9750.

So you can ignore the first two and last three lines since they are not accessible via the UTEC interface.

Thanks,

Jason
ScoobieSnaX is offline   Reply With Quote
Old 11-18-2002, 09:24 PM   #21
jjunior887
Scooby Specialist
 
Member#: 16738
Join Date: Mar 2002
Chapter/Region: MAIC
Location: Charles Town, WV
Vehicle:
2015 WRX Limited
CWP

Default

Nevermind, I think I figured it out. This Laptop sucks a$$, I just reloaded the software and it seems to be ok. Thanks Jason -James
jjunior887 is offline   Reply With Quote
Old 11-19-2002, 01:24 AM   #22
ScoobieSnaX
Scooby Specialist
 
Member#: 10844
Join Date: Oct 2001
Location: location, location...
Vehicle:
2004 Acura TL Navi
Pearl

Default

Be aware that a glitch does exist where the Options form will stay active, thus "UTECLogger.exe" will not be shut down. You'll either have to close it with task manager or Windows 9x, ctrl-alt-del.

Contact me for a fix.
ScoobieSnaX is offline   Reply With Quote
Old 11-19-2002, 08:40 PM   #23
jlw
Scooby Newbie
 
Member#: 12654
Join Date: Nov 2001
Location: Southport, CT
Vehicle:
02 WRX Sdn, 2.5L
Element Tuning GT65r/hdrs

Default

I like the logger. It provides a basic & convenient access to map data points as well as log files.

Given the icon, I want to say something like, "it isn't worth [email protected]", "I'm flushed with excitement", "oh, poop", "I think your really just a (water) closet programmer", "why did you pick a throne". But I won't, we are supposed to keep things sanitized per i-club rules.
jlw is offline   Reply With Quote
Old 11-19-2002, 08:47 PM   #24
ScoobieSnaX
Scooby Specialist
 
Member#: 10844
Join Date: Oct 2001
Location: location, location...
Vehicle:
2004 Acura TL Navi
Pearl

Default

LOL!!!

Nice.....I like that idea. I might change the icon in the next release but for now, the "throne" is where most of the creativity is spawned

I'm nearing completion of the next version which will have basic communications ability. I hope to have the ability to set UTEC parameters (user/tuner/special constants) and upload maps/etc.

Thanks!

Jason
ScoobieSnaX is offline   Reply With Quote
Old 11-19-2002, 09:09 PM   #25
jjunior887
Scooby Specialist
 
Member#: 16738
Join Date: Mar 2002
Chapter/Region: MAIC
Location: Charles Town, WV
Vehicle:
2015 WRX Limited
CWP

Default

most people take a newspaper or a magazine, it sounds like Jason takes his laptop. Dude I hope your the only one that uses that thing.
jjunior887 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox 2.0 Official Release... IE7 FTL 2k2 Off-Topic 13 10-24-2006 10:38 PM
ECUExplorer Datalogger 3.0.25 released today for 2006 WRX.. riggs Engine Management & Tuning 22 02-17-2006 09:00 PM
widest rim on sti? 8.5,9.0,9.5,10???? sambains Impreza Forum 3 06-18-2005 08:24 AM
UTECLogger 1.2 RELEASED!! ScoobieSnaX Engine Management & Tuning 2 12-11-2002 09:55 PM
UTEC Map Compare Tool 0.9.1 Released paul99se Engine Management & Tuning 0 11-19-2002 10:55 PM

All times are GMT -4. The time now is 12:37 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.