Welcome to the North American Subaru Impreza Owners Club Monday October 26, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-29-2016, 09:13 PM   #526
joostin420
Scooby Specialist
 
Member#: 1046
Join Date: Mar 2000
Location: New England, United States
Vehicle:
2020 WRX Limited
Ice silver metallic

Default HELP Please

Quote:
Originally Posted by Vector View Post
Link to large image: https://picasaweb.google.com/lh/phot...eat=directlink

This is of course specific to my setup (DDX-9902S, maestro RR)

I am installing a maestro rr with kenwood head unit, so my wiring should be almost identical to Vector***8217;s diagram posted.

I have a kenwood dnn991hd head unit; I did look up his models manual to compare which appears to use the same 16 pin harness as his kenwood ddx-9902s. I don***8217;t think the kenwood harness has changed at all. this is not my first aftermarket head unit install by far, but the 2016 wrx is a little different from previous years.

From Vector***8217;s diagram I have a few questions; I know there are some other kenwood installs in this thread, and that phd12v works for maestro and hopefully sees this post and has some insight. I have wired the oem backup camera with a 12v-6v step-down as well exactly like the diagram.

1. I used the autoharnesshouse 28-pin Head Unit Wiring Harness Adapter and cut the end off.

2. I used the metra 70-1761 harness set (10 and 6 pin harnesses) for the Subaru/vehicle side taps. Do you leave the loop/splice between pin-6 and pin-7?

3. On Vector***8217;s diagram the kenwood harness pin-3 (blue/white - p.cont) goes to pin-6 on the Subaru 10 pin vehicle harness. Is this correct?

4. On Vector***8217;s diagram the kenwood harness pin-12 (light blue/yellow - steering wheel remote input) goes to pin-7 on the Subaru 10 pin vehicle harness. Is this correct?

5. On Vector***8217;s he did not use the kenwood harness pin-4 (blue ***8211; antenna control wire); is this not needed on the MY16 wrx?

I am using the 40-LX11 adapter for the antenna connection; from what I have read the blue wire from this adapter is not used. Is this correct?

6. I could not find an official install guide on the maestro website for the 2016 wrx. I see from Vector***8217;s diagram that he attached both the ***8220;H***8221; connector and ***8220;D***8221; connector from the maestro rr to the kenwood head unit. Is this correct?

7. I flashed the maestro rr about 2 weeks ago.

If I need/should change wiring or anything else at all I am more than willing in order to make the best before installing.

I really appreciate everyone***8217;s help in advance.

Thank you,

justin
* Registered users of the site do not see these ads.

Last edited by joostin420; 03-29-2016 at 09:42 PM.
joostin420 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-30-2016, 09:59 AM   #527
Nuked
Scooby Newbie
 
Member#: 110329
Join Date: Mar 2006
Chapter/Region: MAIC
Location: Morgantown, WV
Vehicle:
2016 Mustang GT PP
Triple Yellow

Default

On mine, the pin 6 and 7 that are jumped, I hooked the one that has the longer blue wire on the Metra adapter to my 12volt acc source (red wire). That gives the antenna booster 12 volts whenever the switch is on. So far works fine, AM/FM/HD picks up like factory.

Blue wire on 40-LX11 does not need connected. It is dead ended at the plug on factory side.

Those are the only two I can help you with, as I have a Pioneer. See my next post for thoughts on that lol.
Nuked is offline   Reply With Quote
Old 03-30-2016, 10:02 AM   #528
Nuked
Scooby Newbie
 
Member#: 110329
Join Date: Mar 2006
Chapter/Region: MAIC
Location: Morgantown, WV
Vehicle:
2016 Mustang GT PP
Triple Yellow

Default

Any other Pioneer folks having issues with a static/digital noise when using an iPod? All other sources are fine, just when using my ipod. I tried both USB connections and changed out lightening cables to no avail. A google search brought a couple examples up, but they were older threads with no fix so far. Just wondering if anyone here has ran into the issue and if so what kind of fix or firmware your running if not having problems.

SQ
Nuked is offline   Reply With Quote
Old 03-30-2016, 10:48 AM   #529
phd12v
Scooby Specialist
 
Member#: 432497
Join Date: Oct 2015
Chapter/Region: MAIC
Location: Pitt
Vehicle:
18 Sti
ISM

Default

Quote:
Originally Posted by joostin420 View Post
I am installing a maestro rr with kenwood head unit, so my wiring should be almost identical to Vector’s diagram posted.

I have a kenwood dnn991hd head unit; I did look up his models manual to compare which appears to use the same 16 pin harness as his kenwood ddx-9902s. I don’t think the kenwood harness has changed at all. this is not my first aftermarket head unit install by far, but the 2016 wrx is a little different from previous years.

From Vector’s diagram I have a few questions; I know there are some other kenwood installs in this thread, and that phd12v works for maestro and hopefully sees this post and has some insight. I have wired the oem backup camera with a 12v-6v step-down as well exactly like the diagram.

1. I used the autoharnesshouse 28-pin Head Unit Wiring Harness Adapter and cut the end off.

2. I used the metra 70-1761 harness set (10 and 6 pin harnesses) for the Subaru/vehicle side taps. Do you leave the loop/splice between pin-6 and pin-7?

3. On Vector’s diagram the kenwood harness pin-3 (blue/white - p.cont) goes to pin-6 on the Subaru 10 pin vehicle harness. Is this correct?

4. On Vector’s diagram the kenwood harness pin-12 (light blue/yellow - steering wheel remote input) goes to pin-7 on the Subaru 10 pin vehicle harness. Is this correct?

5. On Vector’s he did not use the kenwood harness pin-4 (blue – antenna control wire); is this not needed on the MY16 wrx?

I am using the 40-LX11 adapter for the antenna connection; from what I have read the blue wire from this adapter is not used. Is this correct?

6. I could not find an official install guide on the maestro website for the 2016 wrx. I see from Vector’s diagram that he attached both the “H” connector and “D” connector from the maestro rr to the kenwood head unit. Is this correct?

7. I flashed the maestro rr about 2 weeks ago.

If I need/should change wiring or anything else at all I am more than willing in order to make the best before installing.

I really appreciate everyone’s help in advance.

Thank you,

justin
4. the blue yellow is not required when you connect a full maestro capable radio, dont need it connected.

6. the 4 pin to 4 pin data cable is required yes, the 3 pin to 3.5mm jack is not, since we are not feeding audio from the car to the headunit, nor are we integrating the factory mic. look at my previous post, that is the normal install for the maestro rr with the additional camera output which you wont need since you have the adapter already.
phd12v is offline   Reply With Quote
Old 03-31-2016, 08:48 AM   #530
phd12v
Scooby Specialist
 
Member#: 432497
Join Date: Oct 2015
Chapter/Region: MAIC
Location: Pitt
Vehicle:
18 Sti
ISM

Default

for you guys with the RR that has (512) on it...you have the latest version of the RR and i need to get the BETA firmware to that platform, it is only written for the (256) model as of right now. Give me a few hours to get it moved over.

EDIT: we are going to make it a live firmware today, so it will be updated to version 1.6 in a couple hours. you will not need to send me any more info for modules, or your user names once 1.6 goes up.

Last edited by phd12v; 03-31-2016 at 09:18 AM.
phd12v is offline   Reply With Quote
Old 03-31-2016, 09:46 AM   #531
nodrog321
Scooby Newbie
 
Member#: 394477
Join Date: Jun 2014
Chapter/Region: Tri-State
Location: Queens, NYC
Vehicle:
2016 WRX Limited
CWP

Default

Still waiting for my USB adapter and some other misc. parts. Then I need to figure out the whole wiring mess lol.

Are you guys running your HDMI cables somewhere? Any way to get it in the armrest compartment? Glove would probably be easiest but if I want to screen mirror, it would be nice to have the HDMI in the armrest so I can charge as well without all the wires being out in the open.
nodrog321 is offline   Reply With Quote
Old 03-31-2016, 10:48 AM   #532
phd12v
Scooby Specialist
 
Member#: 432497
Join Date: Oct 2015
Chapter/Region: MAIC
Location: Pitt
Vehicle:
18 Sti
ISM

Default

you would have to cut a hole in the armrest area, but doable if you want
phd12v is offline   Reply With Quote
Old 03-31-2016, 12:04 PM   #533
Andrew025
Scooby Specialist
 
Member#: 303408
Join Date: Dec 2011
Chapter/Region: NWIC
Location: Portland, Or
Vehicle:
04 STi
WRB

Default

Quote:
Originally Posted by nodrog321 View Post
Still waiting for my USB adapter and some other misc. parts. Then I need to figure out the whole wiring mess lol.

Are you guys running your HDMI cables somewhere? Any way to get it in the armrest compartment? Glove would probably be easiest but if I want to screen mirror, it would be nice to have the HDMI in the armrest so I can charge as well without all the wires being out in the open.
I pulled my center console out and ran it underneath and made a hole in the arm rest compartment.
The center console comes out pretty easily.
Andrew025 is offline   Reply With Quote
Old 03-31-2016, 12:09 PM   #534
nodrog321
Scooby Newbie
 
Member#: 394477
Join Date: Jun 2014
Chapter/Region: Tri-State
Location: Queens, NYC
Vehicle:
2016 WRX Limited
CWP

Default

Quote:
Originally Posted by phd12v View Post
you would have to cut a hole in the armrest area, but doable if you want
Quote:
Originally Posted by Andrew025 View Post
I pulled my center console out and ran it underneath and made a hole in the arm rest compartment.
The center console comes out pretty easily.
Thanks guys. I'll have to pull everything apart to see if its worth it. In my old car, the 12V port assembly comes out after removing a screw so I was able to just cut the corner for that assembly a little bit and run the wire thru from there. Didn't look like the 12V/AUX assembly comes out in the WRX from first glance. I'll have to take a look.
nodrog321 is offline   Reply With Quote
Old 04-01-2016, 01:45 AM   #535
Midnite8
Scooby Specialist
 
Member#: 430858
Join Date: Sep 2015
Chapter/Region: BAIC
Location: Pleasanton, CA
Vehicle:
2016 WRX Premium
World Rally Blue

Default

I am looking to get a new HU but really only have a budget around $200-300.. any suggestions?
Midnite8 is offline   Reply With Quote
Old 04-01-2016, 01:38 PM   #536
aigochamaloh
Scooby Newbie
 
Member#: 188167
Join Date: Aug 2008
Chapter/Region: SCIC
Vehicle:
2016 WRX LBP 6MT

Default

It's been awhile since I've put aside my project since harnesses weren't available. I uninstalled my android headunit out of my 2015 and it's been sitting since.

What are the options available for harnesses now? I haven't been able to reach David still. The Axxess AX-SUB28SWC is the equivalent? Anyone remember the other website that makes harnesses? I can't seem to find it.

edit: Actually that Axxess is plug and play for their steering wheel control unit. My headunit maps the buttons directly so I won't need that.
aigochamaloh is online now   Reply With Quote
Old 04-01-2016, 02:17 PM   #537
phd12v
Scooby Specialist
 
Member#: 432497
Join Date: Oct 2015
Chapter/Region: MAIC
Location: Pitt
Vehicle:
18 Sti
ISM

Default

just jump the 3 wires out, you dont have to use the AXXESS unit
phd12v is offline   Reply With Quote
Old 04-01-2016, 02:19 PM   #538
phd12v
Scooby Specialist
 
Member#: 432497
Join Date: Oct 2015
Chapter/Region: MAIC
Location: Pitt
Vehicle:
18 Sti
ISM

Default

Quote:
Originally Posted by Midnite8 View Post
I am looking to get a new HU but really only have a budget around $200-300.. any suggestions?
look at that kenwood 573....it was like 250 on amazon


http://www.kenwood.com/usa/car/navig...edia/ddx573bh/
phd12v is offline   Reply With Quote
Old 04-01-2016, 08:15 PM   #539
joostin420
Scooby Specialist
 
Member#: 1046
Join Date: Mar 2000
Location: New England, United States
Vehicle:
2020 WRX Limited
Ice silver metallic

Default

Quote:
Originally Posted by phd12v View Post
4. the blue yellow is not required when you connect a full maestro capable radio, dont need it connected.

6. the 4 pin to 4 pin data cable is required yes, the 3 pin to 3.5mm jack is not, since we are not feeding audio from the car to the headunit, nor are we integrating the factory mic. look at my previous post, that is the normal install for the maestro rr with the additional camera output which you wont need since you have the adapter already.
still have a few questions that I need further info please:

3. On Vector***8217;s diagram the kenwood harness pin-3 (blue/white - p.cont) goes to pin-6 on the Subaru 10 pin vehicle harness. Is this correct?

5. On Vector***8217;s he did not use the kenwood harness pin-4 (blue ***8211; antenna control wire); is this not needed on the MY16 wrx?

* is Nuked correct that I need to attach the longer blue wire on the metra 70-1761 harness set (10 and 6 pin harnesses) to my 12volt acc source (red wire). That gives the antenna booster 12 volts whenever the switch is on.

thank you,

justin

Last edited by joostin420; 04-01-2016 at 09:31 PM.
joostin420 is offline   Reply With Quote
Old 04-02-2016, 01:03 AM   #540
tigerdongal
Scooby Newbie
 
Member#: 305772
Join Date: Jan 2012
Chapter/Region: TXIC
Location: San Antonio TX
Vehicle:
2016 WRX STi
Dark Gray

Default

Anyone having problems with the metra double din kit? I cannot get it to fit properly with the 4200 NEX. Any 4100 folks had any issues, as.I would imagine it is exactly the same dimensions. It seems like the opening is not wide enough.
tigerdongal is offline   Reply With Quote
Old 04-02-2016, 01:07 AM   #541
rwd_to_awd
Scooby Newbie
 
Member#: 429584
Join Date: Sep 2015
Location: Oakland, CA
Vehicle:
2016 WRX (base)
WR Blue

Default

Quote:
Originally Posted by tigerdongal View Post
Anyone having problems with the metra double din kit? I cannot get it to fit properly with the 4200 NEX. Any 4100 folks had any issues, as.I would imagine it is exactly the same dimensions. It seems like the opening is not wide enough.
4100 seems to fit fine:
http://forums.nasioc.com/forums/show...&postcount=471
rwd_to_awd is offline   Reply With Quote
Old 04-02-2016, 01:19 AM   #542
dnkngs
Scooby Newbie
 
Member#: 278559
Join Date: Apr 2011
Location: Northern VA
Vehicle:
2015 WRX STi
Crystal Black Silica

Default

Quote:
Originally Posted by phd12v View Post
AX-SUB28SWC for the 28 pin plug http://www.crutchfield.com/p_120SUB2...9482305&awdv=c

70-1761 for the 10 pin and 6 pin Amazon.com: Metra 70-
1761 Radio Wiring Harness For Toyota 87-Up Power 4 Speaker: Car Electronics



AX-SUBUSB for the factory usb port and aux input Amazon.com: AXXESS AX-SUBUSB - USB-Auxilliary Retention Harness - SUBARU 4 PIN USB ADAPTOR: Car Electronics


40-LX11 for the antenna for Am/Fm Amazon.com: Metra 40-LX11 Antenna Adaptor Cable - Select 2009-Up Lexus/Toyota: Car Electronics


99-8907HG for kit for dash (single or double din capable) Amazon.com: Metra 99-8907HG Single DIN Dash Kit for Select 2015- Subaru Impreza and Crosstrek Vehicles (Black): Car Electronics


For steering wheel control you can use the Maestro SW (OR ASWC-1) and add a 6 volt converter for camera trigger, or use a Maestro RR with an upcoming firmware to handle the camera trigger and SWC and supply gauges to a compatible radio

MAESTRO RR- http://www.ebay.com/itm/iDatalink-Ma...UAAOSwiLdV-Mc2
OR
MAESTRO SW- http://www.ebay.com/itm/iDATALINK-MA...QAAOxyjxlTK6th

Here is the list for doing it yourself, the only thing i dont have is the SAT antenna listed, i dont have a part number for that.

Everything i have listed is what i am using in my own car (except the 28 pin adaptor, which i just found out today about, i have some good friends at metra that told me they just started shipping it)

Hi guys, just wondering if this setup will be ok for a 2015 WRX STI w/ NO NAV. I assume it is the same but just want to make sure. Please let me know thanks!!
dnkngs is offline   Reply With Quote
Old 04-02-2016, 12:32 PM   #543
tigerdongal
Scooby Newbie
 
Member#: 305772
Join Date: Jan 2012
Chapter/Region: TXIC
Location: San Antonio TX
Vehicle:
2016 WRX STi
Dark Gray

Default

Quote:
Originally Posted by rwd_to_awd View Post
Do you have the metra din holder and did u use the two additional screws to mount to the lower brackets?
tigerdongal is offline   Reply With Quote
Old 04-02-2016, 01:26 PM   #544
Nuked
Scooby Newbie
 
Member#: 110329
Join Date: Mar 2006
Chapter/Region: MAIC
Location: Morgantown, WV
Vehicle:
2016 Mustang GT PP
Triple Yellow

Default

Quote:
Originally Posted by tigerdongal View Post
Anyone having problems with the metra double din kit? I cannot get it to fit properly with the 4200 NEX. Any 4100 folks had any issues, as.I would imagine it is exactly the same dimensions. It seems like the opening is not wide enough.
I didn't have any problems with it being wide enough. Only issue I had was the headunit is sunk in a little more then I would like on the top. I have to go in today and swap out an iPod cable, so I will take another look at everything.

I did not use the lower two screws that go from the bracket to the HVAC area. Just have mine mounted at the top. It is very secure this way, but I am thinking if I shim the top mounts a little bit it will push the unit out more flush.

SQ
Nuked is offline   Reply With Quote
Old 04-02-2016, 01:56 PM   #545
tigerdongal
Scooby Newbie
 
Member#: 305772
Join Date: Jan 2012
Chapter/Region: TXIC
Location: San Antonio TX
Vehicle:
2016 WRX STi
Dark Gray

Default

Quote:
Originally Posted by Nuked View Post
I didn't have any problems with it being wide enough. Only issue I had was the headunit is sunk in a little more then I would like on the top. I have to go in today and swap out an iPod cable, so I will take another look at everything.

I did not use the lower two screws that go from the bracket to the HVAC area. Just have mine mounted at the top. It is very secure this way, but I am thinking if I shim the top mounts a little bit it will push the unit out more flush.

SQ
So u used the metra frame or the stock metal one? Problem I'm having is being able to get the face off and on.

Last edited by tigerdongal; 04-02-2016 at 02:18 PM.
tigerdongal is offline   Reply With Quote
Old 04-02-2016, 02:52 PM   #546
rwd_to_awd
Scooby Newbie
 
Member#: 429584
Join Date: Sep 2015
Location: Oakland, CA
Vehicle:
2016 WRX (base)
WR Blue

Default

Quote:
Originally Posted by tigerdongal View Post
Do you have the metra din holder and did u use the two additional screws to mount to the lower brackets?
I did not do the installation myself, but I am sure other people on this thread can give installation advice. After all, there is only 1 dash kit that exists for '16 WRX right now so pretty much all of us are using it.
rwd_to_awd is offline   Reply With Quote
Old 04-02-2016, 07:40 PM   #547
Terryister
Scooby Newbie
 
Member#: 442902
Join Date: Mar 2016
Location: Cocoa Beach, FL
Vehicle:
2016 WRX Limited
WRB

Default

Quote:
Originally Posted by aigochamaloh View Post
I haven't been able to reach David still.
I have also tried to get a hold of David to see if I can get the feeder cable to keep the stock sat antenna but haven't had any luck. Does anyone know of anywhere else to get parts he sells?
Terryister is offline   Reply With Quote
Old 04-03-2016, 06:55 AM   #548
baluyot
Scooby Newbie
 
Member#: 443949
Join Date: Apr 2016
Question Connecting AX-SUB28SWC and AX-CAM6V

Hi. Has anyone tried connecting AX-SUB28SWC and AX-CAM6V? Its not very clear to me how to wire them up. One poster in Crutchfield said (if I interpret it correctly):

- AX-SUB28SWC yellow wire connects to AX-CAM6V blue/red
- AX-SUB28SWC red wire connects to AX-CAM6V blue/white
- AX-SUB28SWC black wire connects to AX-CAM6V black

The only thing I'm certain of is the black wire which is ground. But because the color does not match for the other two I'm worried to break something if I wire them up incorrectly. Can anyone confirm if this is correct?

Thanks.
baluyot is offline   Reply With Quote
Old 04-03-2016, 11:26 AM   #549
Nuked
Scooby Newbie
 
Member#: 110329
Join Date: Mar 2006
Chapter/Region: MAIC
Location: Morgantown, WV
Vehicle:
2016 Mustang GT PP
Triple Yellow

Default

Quote:
Originally Posted by tigerdongal View Post
So u used the metra frame or the stock metal one? Problem I'm having is being able to get the face off and on.
I used the metal brackets. I haven't tried taking the face off, but it does tilt fine.
Nuked is offline   Reply With Quote
Old 04-03-2016, 03:44 PM   #550
tigerdongal
Scooby Newbie
 
Member#: 305772
Join Date: Jan 2012
Chapter/Region: TXIC
Location: San Antonio TX
Vehicle:
2016 WRX STi
Dark Gray

Default

Quote:
Originally Posted by baluyot View Post
Hi. Has anyone tried connecting AX-SUB28SWC and AX-CAM6V? Its not very clear to me how to wire them up. One poster in Crutchfield said (if I interpret it correctly):

- AX-SUB28SWC yellow wire connects to AX-CAM6V blue/red
- AX-SUB28SWC red wire connects to AX-CAM6V blue/white
- AX-SUB28SWC black wire connects to AX-CAM6V black

The only thing I'm certain of is the black wire which is ground. But because the color does not match for the other two I'm worried to break something if I wire them up incorrectly. Can anyone confirm if this is correct?

Thanks.
I believe you are correct sir.
tigerdongal is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 03:29 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.