Welcome to the North American Subaru Impreza Owners Club Tuesday August 22, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-14-2017, 11:03 PM   #1
Brenndenmf
Scooby Newbie
 
Member#: 441380
Join Date: Feb 2016
Default Starting issue

So I replaced all the gaskgask on my subaru, and made it to putting everything back in the car. I gohave to turn it on and there is a bunch of fast clicks. Sounds like the starter is trying I think.
Question 1. How many connections are for the starter.

Question 2. Would any other connections cause this issue?

Question 3. How man cracking amps do you need on a battery?
* Registered users of the site do not see these ads.
Brenndenmf is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-14-2017, 11:46 PM   #2
Charlie-III
Scooby Guru
 
Member#: 30669
Join Date: Dec 2002
Chapter/Region: Tri-State
Location: USA, North NJ, 07456
Vehicle:
1998 Legacy 2.5GT
Silver Sleeper BK, 5MT

Default

Sounds like a dead/low battery, either charge it up or jump start it.

There are 3 connections for the starter.
Big red wire from the battery is main feed.
Small wire is part of themstarter circuit.
Bolt or nut that holds the starter to the trans is the ground.

The clicking means there is enough voltage to pull the starter solenoid in (small wire) but not enough to hold it in or spin the starter motor.
Charlie-III is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 09:43 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.