Welcome to the North American Subaru Impreza Owners Club Sunday March 26, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-18-2005, 07:00 PM   #1
BLACKUTECSTI04
Scooby Newbie
 
Member#: 74702
Join Date: Nov 2004
Question Need help w/ JDM Cluster on STI

I just got a JDM Cluster for an STI, i have a 2004 STI and when i installed the JDM, the lights on it dont work... the backlighting... on my stock one it was red, and this one should be green... all the gauge arrows work, the diff too. just when its night time i cant see anything... also the boost gauge, temp. heat. stuff doesn't light up either... can someone help?
* Registered users of the site do not see these ads.
BLACKUTECSTI04 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-18-2005, 07:46 PM   #2
BLACKUTECSTI04
Scooby Newbie
 
Member#: 74702
Join Date: Nov 2004
Default

Bump!
BLACKUTECSTI04 is offline   Reply With Quote
Old 01-18-2005, 08:26 PM   #3
BLACKUTECSTI04
Scooby Newbie
 
Member#: 74702
Join Date: Nov 2004
Default

Bump! Help plz
BLACKUTECSTI04 is offline   Reply With Quote
Old 01-19-2005, 10:30 AM   #4
smdandb2
Scooby Specialist
 
Member#: 70656
Join Date: Sep 2004
Chapter/Region: RMIC
Location: Trampoline Land
Vehicle:
Old Mazda3 Hatch
Shelby Lancer #623

Default

It sounds like you popped the illumination fuse. I would check that first.

You want to sell your stock cluster?
smdandb2 is offline   Reply With Quote
Old 01-19-2005, 03:23 PM   #5
Subahaulic
Scooby Specialist
 
Member#: 51163
Join Date: Dec 2003
Location: northern virginia
Vehicle:
02-5 02WRXwgn &05FXT
sedona & cayenne red

Default

Maybe it's set on dim--have you adjusted the brightness control?
Subahaulic is offline   Reply With Quote
Old 01-19-2005, 06:27 PM   #6
BLACKUTECSTI04
Scooby Newbie
 
Member#: 74702
Join Date: Nov 2004
Default cluster

Quote:
Originally Posted by smdandb2
It sounds like you popped the illumination fuse. I would check that first.

You want to sell your stock cluster?


i will sel the stock sti cluster if i can fix my jdm one to work... its the wiring setup..
BLACKUTECSTI04 is offline   Reply With Quote
Old 01-19-2005, 08:27 PM   #7
smdandb2
Scooby Specialist
 
Member#: 70656
Join Date: Sep 2004
Chapter/Region: RMIC
Location: Trampoline Land
Vehicle:
Old Mazda3 Hatch
Shelby Lancer #623

Default

If I had a wiring diagram, I could tell you exactly what is wrong. I am the cluster master. I've had 4 different clusters in my Ranger, including a Civic Si cluster, lol.

I am going to assume the lighting circuit is different, but what doesnt make sense is if the STi cluster is plug in play on the 02s, it should go both ways. Did you check the fuse? What happens if you hook the stock STi cluster back up?
smdandb2 is offline   Reply With Quote
Old 01-19-2005, 11:28 PM   #8
StevieD
Scooby Specialist
 
Member#: 14029
Join Date: Jan 2002
Location: Texas
Default

I've tried a couple of the JDM ones on WRX's and they are very dim.. I have no idea why. You could check all of your fuses very quickly as a sanity check.
StevieD is offline   Reply With Quote
Old 01-19-2005, 11:59 PM   #9
smdandb2
Scooby Specialist
 
Member#: 70656
Join Date: Sep 2004
Chapter/Region: RMIC
Location: Trampoline Land
Vehicle:
Old Mazda3 Hatch
Shelby Lancer #623

Default

Like I said, it should be working. If I can plug an STi cluster into my bugeye and have illumination, it should work the same on plugging a bugeye cluster into an STi.

Maybe your cluster is toast.
smdandb2 is offline   Reply With Quote
Old 01-20-2005, 12:41 AM   #10
smdandb2
Scooby Specialist
 
Member#: 70656
Join Date: Sep 2004
Chapter/Region: RMIC
Location: Trampoline Land
Vehicle:
Old Mazda3 Hatch
Shelby Lancer #623

Default

I guess on installing a STi cluster in a bugeye, you have to whack one wire on the harness... b28. Damnit I wish I had a wiring diagram, this would be easy to figure out.
smdandb2 is offline   Reply With Quote
Old 01-30-2005, 11:53 PM   #11
BLACKUTECSTI04
Scooby Newbie
 
Member#: 74702
Join Date: Nov 2004
Default Wiring Diagram

Quote:
Originally Posted by smdandb2
I guess on installing a STi cluster in a bugeye, you have to whack one wire on the harness... b28. Damnit I wish I had a wiring diagram, this would be easy to figure out.

I have found the wiring diagram, and the cluster works in a 2004 wrx, but if u check this diagram out the wrx doesnt need 4 extra illumination pinouts... the only thing i dont understand is what wires i need to run to the 2 + and the 2 -.

http://www.ds1motorsports.com/cluster.html
BLACKUTECSTI04 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
JDM experts, need help for JDM STI V8 (EJ207) urgently! curiousgeorge2k5 Subaru Conversions 25 01-20-2016 04:05 AM
Need help w/ JDM V8 Cluster on 04 STI Rustyr6 Electrical & Lighting 4 10-03-2005 01:54 PM
Need help with AVCR install on STi ninjaboy76 Electrical & Lighting 2 09-09-2005 01:07 PM
need help -real invioce price on sti ps99115 General Community 95 07-08-2005 08:54 AM
Need help fast, what power on a JDM STI block? Roffa Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 9 09-04-2004 06:28 PM

All times are GMT -4. The time now is 09:36 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.